Pending with 100 % discount

Events Made Easy Forums Bug fixed or feature request implemented Pending with 100 % discount

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #61446
    JanD
    Participant

    For me so far it looks like a bug but as always I can’t rule out that I am doing it wrong of didn’t sse the logic behind it:

    For the event the following options are marked:
    – Require booking approval
    – Auto-approve booking upon payment

    There exist discounts of 100 %, so that there is nothing to pay, but instead of considering the booking approved and sending the corresponding mail, the status is pending.

    #61447
    Franky
    Keymaster

    While this is not a real bug (it works as designed), I do get the problem. This should fix it:
    https://plugins.trac.wordpress.org/changeset/2338871/

    #61460
    JanD
    Participant

    Thank you.

    #61462
    JanD
    Participant

    One more thing. Now both mails are sent, the pending mail and the approved mail. What would be the best way to prevent the pending mail if 100 % discount is entered in the registration form? And both, for respondent and contact person.

    #61463
    Franky
    Keymaster

    Ok, this fixes that: https://plugins.trac.wordpress.org/changeset/2340920/
    However, the mail for approved bookings will then be sent out. Eiter disable that globally or – if you want to disable it for one event – create an empty template and assign it to the approved mail template mail body for that event (mails with empty content are not sent).
    Maybe I’ll add an option for those, to make it easier …

    #61466
    JanD
    Participant

    I am not sure if I understand correctly. Not everybody is using the 100 % discount for that event. So sometimes there is the pending situation which means pending mails for respondent and administrator and sometimes, with 100 % discount or after paying, the approved mails should be sent.

    #61467
    Franky
    Keymaster

    That stays as is. And with “approval mail” and “pending mail” being both sent, I guess you meant the payment mail and the pending mail (not the approval mail). Try the change first

    #61468
    JanD
    Participant

    Yes, it is working as intended. Merci beaucoup!

    But I made another discovery: The paid_status 1 is still showing the booking that wasn’t paid but reduced 100 % manually by admin editing. And so is the tag #_IS_PAID not having the value 1.

    #61469
    Franky
    Keymaster

    You mean that you set the discount to 100% in the backend and then expect the booking to be marked as paid and possibly also auto-approved? I’m not too much in favor of that …

    #61473
    JanD
    Participant

    I understand and think this is also an exception in my case. Would it be easy to do these settings manually in the database or directly asked: do you mind telling me how to do it?

    #61477
    Franky
    Keymaster

    Just add the 100% discount when editing the booking (and if wanted: select the option to not send a mail after editing the booking).
    After that, just select the pending bookings you want and click the button “Mark paid and approve”.

    #61481
    JanD
    Participant

    I opened the editor of this specific pending booking and entered the full price in the discount field. I can’t remember but I guess I approved the booking afterwards as you discribed. In any case it is listed now in the Approved Bookings section. But there in the list it is also to see that in the ‘Paid’ column is written ‘No’ even if the ‘Total Price’ is ‘0,00 €’. And I guess that is why this booking is shown/not shown everywhere where I filter for pay status. I don’t find where to change this flag. All other 100 % discount user – who entered the code correctly – are listed as Paid Yes.

    #61482
    Franky
    Keymaster

    Then select that booking in the list and use the mass option “mark paid” 🙂
    Edit: there’s a difference between the mass action “aprove booking” and the special button “mark paid and approve”

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.