Events Made Easy Forums Generic Payment Gateway and extra charge gone

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #63699
    kinghill
    Participant

    Hi Franky,

    for ease of use I routinely click the button “mark as paid and approve” when payments arrive for bookings that need approval. And since most of our payments come through bank transfer, this works great.

    But today I noticed that when I click the aforementioned button on payments that were done through Mollie and/or Legacy Paypal all of sudden the Payment Gateway and extra charge get removed, the corresponding columns are empty and there’s no trace of these payments left anymore. Even the “Payment received” column shows a wrong amount when compared to my Mollie/PayPal receipts respectively.

    So my question is – is this a feature or bug of EME?
    Mustn’t I click the button but always use “Approve booking” from the dropdown only?

    And a related questions – can I re-introduce the missing data through edits in the database via phpMyAdmin?

    Thanks

    #63700
    kinghill
    Participant

    PS: I have one event type with auto-approving on payment – here everything works fine. And if I use the “Approve Booking” dropdown menu, then all is fine, too.

    #63702
    Franky
    Keymaster

    If you use “mark as paid and approve” on a pending booking that is already paid, it will indeed erase the payment info from any payment gateway. I’ll take that into account for the next version and just do the approve action if already paid.
    The amount received column is in the current situation also completed with the total cost of the booking, but only if empty. So it sounds weird to me that a paid non-approved booking had an empty received value …

    #63703
    kinghill
    Participant

    Thank you! That will reduce errors on my part.

    About the payment received – there’s been a misunderstanding. It’s not empty, it just shows the total price without the extra charge. Probably because payment info is gone, right?

    Can I ask again, though, about adding the missing payment info back in, perhaps through edits in the database via phpMyAdmin?

    #63709
    Franky
    Keymaster

    You can edit it in the db indeed if you’d like.

    #63711
    kinghill
    Participant

    Fantastic, thank you. Worked great, just by adding the corret Payment Gateway (pg) to the database.
    Just one last question, lest I mess something up. There’s also the “Payment GW ID”. Do I need to add this, too? Or is it merely an “admin” field for documentation purposes which can be ignored?

    #63714
    Franky
    Keymaster

    I forgot to reply to this. The “Payment GW ID” is the payment id of the gateway used to make the transaction. It can also be used to reimburse if needed. It is not really required (but for reference you might want to fill in the mollie id there).

    #63715
    kinghill
    Participant

    Thank you for that – good to know. Will do!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.