Events Made Easy Forums Bug fixed or feature request implemented Nonapproved members not being automatically deleted

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #62950
    G_Woman
    Participant

    Hi Franky,

    I have this membership where I set to delete not approved members automatically after 7 days.
    But the member is not being deleted and it is the 8th day after registering now (18th registered 10:14 am).

    Could this be a bug?

    #62951
    Franky
    Keymaster

    Can it be that the start and/or end date for that member are not empty? That would explain it (as first the end date is taken into account, then the start date if end date is empty, then the creation date if start date is empty). Sometimes – upon edit – the end date is not empty and then a pending member is deleted based on that date (and the number of days you configured).
    I guess that in this case only the creation date should be taken into account …

    #62952
    Franky
    Keymaster

    If my assumption is right, this should fix it:
    https://plugins.trac.wordpress.org/changeset/2572380/

    #62953
    G_Woman
    Participant

    Start and enddate are empty indeed!

    I think I’ll just wait for the next update to fix it, I don’t know how to apply your changes, but thanks for looking into it! ^^

    #62954
    Franky
    Keymaster

    If both start and end date are empty, then this is not the problem (nor the solution). Are you sure?
    Is the creation date ok (in the overview for members, check “status”, “start date”, “end date” and “registered on” columns and copy/paste those).

    #62955
    G_Woman
    Participant

    I’m sorry, I already removed the member.

    The registeration date was correct (18th july) but there was an empty start and end date, what I can remember. I opened all the options before to check your earlier statement. I read that you said they should be empty, not ‘not empty’.

    #62957
    Franky
    Keymaster

    They should indeed be “empty”. If “not empty”, then the code wasn’t working as expected.
    But anyway, the code has been adapted to just take the creation date into account.

    #62958
    G_Woman
    Participant

    Ok great 😀

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.