Events Made Easy Forums How do I … How to add persons to a membership?

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #62771
    G_Woman
    Participant

    Hi Franky,

    I encountered this problem, could be I am somehow overlooking functions of EME.

    For our assocation we created a ‘member of honor’-membership, giving them the same rights as premium members (who pay for access to exclusive content), but without paying for it.

    However, since they are honor members, as an association we registered them ourselves as ‘persons’ (it feels weird asking them to fill in the form to become a member of honor…). But after doing that, I can only assign them to a group, not to a membership.

    And if I want to make a page exclusive to certain memberships, I can’t include them.
    A workaround would be to make pages, with [eme_if] codes before it, but that would be a hassle.

    Do you have any idea’s how to solve this? Or should I just ask them to fill in the form and just get over with my problem of etiquette? Or could this maybe be a new feature to be added?

    #62772
    Franky
    Keymaster

    Go into the members admin page and at the top: select the membership of choice and click on “add member” …
    After adding, make sure to make them “active” too by “accepting a payment” (even if it is free) or by manually setting the status to active when creating the member.

    #62773
    G_Woman
    Participant

    Thanks!

    I do feel stupid you know, when there is a button I did not know about, though I have been using the plugin for quite some time now…

    I should make a different topic: somehow if I send an e-mail to this membership members, nothing gets send, but it does appear in the mailings? I did fill in the e-mailaddresses for them?

    “0 mails verzonden, 0 mails gefaald”?

    #62774
    G_Woman
    Participant

    And also, by adding a member that way, you don’t get a WP user account automatically, right?

    #62775
    Franky
    Keymaster

    On the last remark (creating a wp user): correct. That is in fact something I can fix with this change:
    https://plugins.trac.wordpress.org/changeset/2552743/

    Concerning your mails: how do you send these?

    #62835
    G_Woman
    Participant

    Thanks, you are always so quick to adjust!

    I send the mails through Email Management > General mails?

    Eventually I send the emails by adding the persons one by one in the person-field in stead of the member-group field.

    #62836
    Franky
    Keymaster

    Then maybe the “MassMail” option for the relevant people is set to 0 ? Check that, and also the MassMail option in the EME settings, tab “Mail”. And if set to 0, consider using #_OPT_IN or #_OPT_OUT in your membership form when people sign up.

    #62846
    G_Woman
    Participant

    It was set to ‘no’, so I turned this around now. At the moment I don’t have mails te send, so will let you know if this works or not.

    This was put in as info next to the buttons:
    “Moeten nieuwe personen in de databank massa-mails krijgen of niet? Deze optie wordt gebruikt als je niet om hun mail voorkeuren vraagt via opt-in/out in een formulier. Waarschuwing: als je dit op “ja” zet is dit niet GDPR compliant als je niet om mail voorkeuren vraagt via opt-in/out.”

    When people are registering, we do ask them to read and comply with our Privacy Policy. In it, we put in they get mails for certain events. So that means we still are GDPR compliant, right?

    #62848
    Franky
    Keymaster

    Yes, you’re compliant then. But I’d use #_OPT_IN to ask for their mail preferences

    #62900
    G_Woman
    Participant

    I included #_OPT_IN in the sign form.

    Still didn’t send a mail for members yet, but will let you know!

    #62904
    G_Woman
    Participant

    I just tried sending an email to membership members (as membership group), but it didn’t work again (even though I followed your instruction).

    However this time, it did send to the webadmin email? (I did click on a unsub url that I created in an email recently with this account)

    #62907
    Franky
    Keymaster

    You have either “Send to a number of member groups” or “Send to active members belonging to” in the “Generic email” tab. Which one did you use? Or a demo/screenshots/video/… ?

    #62909
    G_Woman
    Participant

    I used ‘Send to active members belonging to’, but it didn’t send.

    And I did check if they were active in the membership. When I filter them in the members area on active members, they do appear.

    #62910
    Franky
    Keymaster

    Can you reproduce that on a test setup? Or with a test membership (and give me temp admin rights to verify)?

    #62912
    Franky
    Keymaster

    Also: is your mail queueing active? And if so, check in “Planned actions” that they get sent in the timeframe of your choice.

    #62913
    G_Woman
    Participant

    Check your mail.

    Yes, my mail queueing is active, but those are being send without problems. I don’t think that is the problem.

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.