Events Made Easy Forums How do I … Get rid of the 6 white lines beneath my booking form title?

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #61809
    janinehe
    Participant

    In my booking form, I see an area of 6 ‘<br>’ lines between the title of my bookingform and the first entry field. How do I get rid of those lines?

    #61810
    Franky
    Keymaster

    Probaly your generated html is wrong so those get added. Do you have an example I can see?

    #61811
    janinehe
    Participant
    #61812
    Franky
    Keymaster

    That doesn’t link to an event since it is for members only. Can’t you create a public event that has the issue?

    #61813
    janinehe
    Participant

    It was supposed to be public. I think I solved that. Thanks for noticing 😉

    #61814
    Franky
    Keymaster

    The br-tags come from the rsvp template. Does that contain extra empty lines? Or set the option to convert newlines to br-tags to “no” for that template.

    #61815
    janinehe
    Participant

    This is my RSVP template:

    <table class=’eme-rsvp-form’>
    <tr><th scope=’row’>Achternaam*:</th><td>#_LASTNAME</td></tr><br />

    <tr><th scope=’row’>Voornaam*:</th><td>#REQ_FIRSTNAME</td></tr><br />

    <tr><th scope=’row’>E-Mail*:</th><td>#_EMAIL</td></tr><br />

    <tr><th scope=’row’>Telefoonnummer*:</th><td>#_PHONE</td></tr><br />

    <tr><th scope=’row’>Plaatsen*:</th><td>#_SEATS</td></tr><br />

    <tr><th scope=’row’>Opmerkingen:</th><td>#_COMMENT</td></tr><br />

    </table>
    <P STYLE=”text-align: center”>#_SUBMIT

    I don’t see the br-tags here. That’s why I’m so confused, cause I do see them when i check the code in my browser.
    Where do I find the option to convert newlines to br-tags to “no”? I looked, but cant find it.

    #61816
    Franky
    Keymaster

    Well, I see the br-tags you posted (but maybe you made a copy/paste error or forgot to use “code” formatting).
    But EME translates extra carriage-returns into br-tags, so make sure your template doesn’t contain empty lines

    #61817
    janinehe
    Participant

    I realize my question was not very clear. I put the single br-tags at the end of every text line myself. Those are not the problem.

    But in between the title of my bookingform and the first entryfield I can see six br-tags which create a large white area.

    I can see them when i inspect my page in my browser. Ik looks like this:

    <input type=”hidden” name=”eme_event_ids[]” value=”36″>
    <br>
    <br>
    <br>
    <br>
    <br>
    <br>
    <table class=”eme-rsvp-form”> etc…

    #61818
    Franky
    Keymaster

    The reason they show there is because in the source code (generated html) the br-tag is present after each closing tr-tag. And because the browser doesn’t accept those br-tags there, it “autocorrects” and shows them before the table.
    So in your case: see my last remark: EME translates extra carriage-returns into br-tags, so make sure your template doesn’t contain empty lines (or diable the nl2br conversion for that template, that is a setting per template).

    #61819
    janinehe
    Participant

    Thanks! Now I understand! Problem solved in 2 seconds and again learned something useful!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.