Events Made Easy Forums How do I … English messages showing instead of translated messages

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #64645
    xaman
    Participant

    Hi Franky,

    I have set up the messages to show both English and Chinese versions in the following way for “Booking recorded message”:

    [:en]
    Your registration has been submitted.
    <br />
    Please check your mailbox for the confirmation mail.
    <br />
    Further information will only be provided after you have confirmed your registration.
    [:zh]
    你的注册已经提交。
    <br />
    请查看你的收件箱中的确认邮件。
    <br />
    进一步的信息只有在你确认注册后才会提供。
    [:]

    I also set the email confirmation email in the following way:
    Subject
    [:en]Registration for '#_EVENTNAME' requires your confirmation[:zh]'#_EVENTNAME' 的预订需要你的确认。[:]

    Body

    [:en]
    Dear #_PERSONFULLNAME,
    
    Your request to register #_RESPSEATS seat(s) for #_EVENTNAME requires your confirmation.
    
    <a href="#_BOOKING_CONFIRM_URL" target="_blank" rel="noopener">PLEASE CLICK ON THIS LINK TO CONFIRM!</a>
    
    If you did not make this registration, you don't need to do anything, it will then be removed automatically.
    
    Regards,
    #_CONTACTPERSON
    
    [:zh]
    亲爱的 #_PERSONFULLNAME,
    <br /><br />
    你为 #_EVENTNAME 预订的 #_RESPSEATS 个座位的请求需要你的确认。 
    <br /><br />
    <a href="#_BOOKING_CONFIRM_URL" rel="noopener" target="_blank">请点击此链接以确认!</a>
    <br /><br />
    如果你没有做这个预订,你不需要做任何事情,它将被自动删除。
    <br /><br />
    祝安康快乐, 
    #_CONTACTPERSON
    [:]

    But when a person registers for the Chinese course, the messages all appear in English. What am I doing wrong here? Or is there another setting that is needed to show the correct language?

    #64646
    Franky
    Keymaster

    Do you have a demo i can see? Which plugin do you use for multilingual support?

    #64650
    xaman
    Participant

    I’m using Polylang + Loco Translate. I have sent you an email with a link to the demo website.

    #64658
    Franky
    Keymaster

    The reason is that the special events page has a polylang language set, this overrides all url-language choices. A workaround (since polylang doesn’t provide a method to remove a language setting from a page):

    – deactivate polylang and events made easy plugins
    – remove the events pages (in all languages, also from draft and trash)
    – reactivate EME (this will create a new events page without language assigned to it)
    – reactivate polylang

    #64659
    xaman
    Participant

    Did as you mentioned and it is showing the translated language as intended. Thanks Franky for resolving the issue.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.