Events Made Easy Forums How do I … Can’t send e-mails reservation for an event in 2.2.0 (blocked in the queue)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #62937
    Ike
    Participant

    Hello Franky,

    Sorry this message is a google translate
    I had a pending project that I started over.

    I was with version 2.1.95 and everything was working fine.
    When I updated to the latest version, both “reservation approved” emails and “registration confirmation” emails stopped being sent.
    By downgrading to the old versions I saw that the problem of sending emails starts with version 2.2.0

    When I look in “Cleanup Action” the messages are in the mail queue. I have tried several configurations in “Scheduled Actions” but the messages are not sent. (in lots of 1, of 5, every minute, once every 5 minutes, etc.)

    Messages are sent “only” if in settings> mail> “Mail queue for later” is unchecked.

    I have a preprod version with the last version eme and a prod version with 2.1.95
    I have exactly the same configurations. With 2.1.95 emails are sent immediately and with 2.2.12 they are sent to the queue and stay blocked.
    Why with 2.2.0 do messages automatically go to the queue?

    What has changed between 2.1.95 and 2.2.0?
    Can you help me solve this problem.

    #62938
    Franky
    Keymaster

    Like said: if the mails are in the queue (which means you have queueing activated), you need to configure the queue send options (see “Scheduled actions” submenu).

    #62939
    Ike
    Participant

    I have tried several configurations in “Scheduled Actions” but the messages are not sent. (in lots of 1, of 5, every minute, once every 5 minutes, etc.)

    How do I configure “shedule options” so that messages are sent within a minute?

    Messages are sent “only” if in settings> mail> “Mail queue for later” is unchecked.

    #62940
    Franky
    Keymaster

    If they are not sent when queueing is active, it means something is wrong with your wordpress cron. If your site doesn’t receive lots of visitors or page loads, your wp cron won’t work as expected if not triggered via system cron.
    See https://kb.wprssaggregator.com/article/195-what-is-wordpress-cron-why-do-i-need-it-and-what-are-the-alternatives

    #62942
    Ike
    Participant

    I solved the problem with your guidance.
    Indeed in my preprod version, access to my directory is protected by a .htaccess file and this prevented the server from accessing wp-cron.php. I saw the problem with the WP Control plugin.
    But why I didn’t have this problem with 2.1.95 remains a mystery 🙂

    Thanks a lot

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.